Index · Правила · Поиск· Группы · Регистрация · Личные сообщения· Вход

Список разделов Компьютерная безопасность, коды, доступы и т.д.
 
 
 

Раздел: Компьютерная безопасность, коды, доступы и т.д. ViPNet CSP 4.2.11 не совместимые контейнеры с версией ниже 

Создана: 22 Июня 2019 Суб 23:16:35.
Раздел: "Компьютерная безопасность, коды, доступы и т.д."
Сообщений в теме: 12, просмотров: 2573

  1. 22 Июня 2019 Суб 23:16:35
    Начал замечать, не очень хорошее и надеялся, что это единичные случаи и сбои в ОС.

    НА бетках ViPNet_CSP контейнер принимает пароль на других нет:
    4.2.11.56905 и 58000 отлично, на ViPNet_CSP_RUS_4.2.8.51670 и ниже нет.
    ....
    У клиента при этом как раз был при запросе и генерации 4.2.11

    Писать в тех.п. при этом бессмысленно т.к. скажут - ну это же бетка и мы предупреждали,
    но а как быть если на Вин 10 не как, с Каспером тоже не как и т.п. кривокосяки.

    Но как можно было тут так накосячить, это не серьёзно, а если учесть,
    что некоторым надо именно вернуться на 4.2.2.36190 т.к. выясняется там какое то ПО налоговое только
    с этой версией работает и т.п., то сюрпризы от таких сбоев и вовсе не очень радостные
    и решения пока скорее всего так и нет.

    Так что быть осторожным и бдить!
    Это всё же почто второй по распространенности СКЗИ который используется не только с ПО ViPNet Client,
    но и со многими бухгалтерскими и прочими программами.
  2. BolenB


    Активист


    Более 10 лет на форумеМуж.
    23 Июня 2019 Вск 9:06:30
    Занимаюсь администрированием. Есть много компьютеров где стоит Windows XP и Астрал отчет. Единственная версия под XP ViPNet_CSP_RUS_4.2.2.36190 нормально не работает. Зато прекрасно работает КриптоПро CSP 4.0 R4 4.0.9963 (Abel) от 23.11.2018.
    Поэтому везде где используется Астрал Отчет перевыпускаю сертификат под CryptoPro, а Vipnet удаляю.
  3. BolenB


    Активист


    Более 10 лет на форумеМуж.
    23 Июня 2019 Вск 9:16:21
    Vipnet CSP нужен только для Vipnnet Client как дополнительный криптопровайдер, а основным должен быть CryptoPro CSP и все подписи надо делать в нем. Тогда и проблем не будет.
  4. 23 Июня 2019 Вск 10:26:40
    BolenB писал : Vipnet CSP нужен только для Vipnnet Client как дополнительный криптопровайдер, а основным должен быть CryptoPro CSP и все подписи надо делать в нем. Тогда и проблем не будет.


    Это верно, но 100% так заверять не стоит, и с КриптоПро есть не мало сложностей,
    для примера тот же Асртал, работающий под Вин-10, после обновления до 1803
    падает, НО не сам он, а SQL, потому тут надо уже использовать только R4 сборки,
    т.е.CSPSetup_4_0_9953_R4 и выше.

    Цитата:КриптоПро CSP 4.0 R4 (несертифицированный, тестовый)
    Предварительная тестовая версия КриптоПро CSP 4.0.9953 от 30.05.2018
    для решения проблем на Windows 10 1803 и Windows 10 RS5.

    КриптоПро CSP 4.0 для WindowsКонтрольная сумма
    ГОСТ: 33BCF924368D3BC0F35EBC3AD209195B5B9E861431B47A59221461F41688DC64
    MD5: e93b7c2d22d37ac3862edcf5747262b2


    Сейчас сертиф. версия "CSPSetup_4_0_9963_R4_с", но есть уже и "CSPSetup_4_0_9969_R5"
    Про 5.х версию пока не горю т.к. хоть и продаётся уже, но пока бетка, хотя в некоторых
    случаях на 10-ке и она спасала.

    НО вернёмся к XP - это действительно у нас проблема т.к. нет у людей (особенно в областях)
    другого железа, а если появляется, то там 10-ка которая пока тоже не где 100% не согласована
    в ФСБ и ФСТЭК и по причине её обновления, которое останавливать уже нет смысла (кто пытается
    только хуже себе делает в итоге) и получаются такие накладки.

    Потому вам просто очень везёт если кто то наконец то понимает, что купить КриптоПро в разы
    дешевле потом выходит, чем восстанавливать данные после того "свободного" криптопровайдера.
    (Хотя чисто для своих целей и по тем требованиям которые он предъявляет всё может работать
    годами, но только сложно многим выполнить эти требования и не чего "лишнего" не ставить).

    Такие же проблемы и с 1С и с другим ПО и сторонними ресурсами (выход на налоговую, торговые
    площадки (кто пробовал на пример на ЕИС [внешняя ссылка] пробиться и т.п. тоже знают там остался
    в работе только КриптоПро..), ЕГАИС и прочее, прочее... и тут XP так же с устаревшим IE и др.
    браузерами просто тихо уходит в сторонку.

    Почему многое ПО завершает поддержку пользователей Windows XP и Vista?

    Это касается не только отечественных СКЗИ, самый наглядный пример браузер ХРОМ,
    Мазила, практически всё новое оборудование (принтер, сканер, и т.п.).

    Дело в том, что Microsoft завершила поддержку Windows XP в 2014 году, а поддержку Windows Vista в 2017 году.
    Неподдерживаемые операционные системы не получают обновления безопасности, имеют известные уязвимости
    и могут быть опасными для использования, что делает сложным их поддержку для этих версий.

    Чтобы получить последние функции и обновления, приходится обновлять операционную систему,
    на версию Windows, которую ещё поддерживает Microsoft, например, на Windows 7, 8 или 10.
    Сейчас практически из данной линейки остаётся только Windows 10, которая хороша для
    обычной домашней работы, но для работы со средствами СКЗИ Российского требования,
    бывает не всё так просто.
    Переход на операционную систему на основе Linux так же часто не выход, т.к. в ней ещё
    больше разных релизов и пока она только начинает охватывать весь спектр услуг и не
    готова заменить то, что было сделано для ОС Windows.


    Недавно пришлось и это проверить показательно
    ViPNet Client 3.2 + XP + ГОСТ 2012 = дружбы не будет


    ===========
    Но я понимаю XP и бла-бла-бла, НО такой подставы не ожидал т.к. свои же контейнеры и не принимать на версии в рамках 4.х,
    даже можно "простить" если бы они на 3.х не читались, но на одной линейки - это они сильно косячнули.

    Вот ещё если интересно
    [внешняя ссылка]

    Цитата:Очень нужен ViPNet CSP 4.2 (2.36190)!
    Для корректной работы программы "Электронный листок нетрудоспособности" от ФСС.


    Ну и вот, стало быть Норм
  5. 23 Июня 2019 Вск 22:42:03
    Вот ещё для "смеха" Смайлик :-) кто в теме сразу поймут Смайлик :-)))

    Ляпы Инфотекс - кто не замечает этого, считайте тест не прошли Very Happy



    Ответ:
  6. 24 Июня 2019 Пон 6:46:02
    В качестве оптимального криптопровайдера на все случаи жизни на данный момент использую криптопро версии 9944.

    Каких только систем у нас нет - не возникает вопросов именно с криптопровайдером.
  7. 24 Июня 2019 Пон 7:14:21
    kinslayer писал : В качестве оптимального криптопровайдера на все случаи жизни на данный момент использую криптопро версии 9944.

    Каких только систем у нас нет - не возникает вопросов именно с криптопровайдером.


    Это версия R3, согласен - отличное решение, к тому же если требется,
    то и сертификат не устарел "CSPSetup_4_0_9944_R3_с"

    Сертифицированная версия КриптоПро CSP 4.0.9944 (Xenocrates) от 22.02.2018.
    Сертификаты соответствия: СФ/114-3379, СФ/124-3380, СФ/114-3382, СФ/124-3383
    от 11.05.2018 действительны до 15.01.2021.


    Там даже впервые начали кнопку "Пересчёт КС" применять, по сравнению с R2, где
    приходилось это через CMD или переустановкой исправлять, чтоб журнала не загаживались,
    при обновлении ОС и смене dll.
    Напомню:
    КриптоПро CSP 4.0 R4 (несертифицированный, тестовый)
    Предварительная тестовая версия КриптоПро CSP 4.0.9953 от 30.05.2018
    для решения проблем на Windows 10 1803 и Windows 10 RS5.

    т.е. всё что выше и текущая серт. версия.

    Сертифицированная версия КриптоПро CSP 4.0.9963 (Abel) от 23.11.2018.
    Сертификаты соответствия:
    1-Base: СФ/114-3610 от 10 января 2019 до 15 января 2021
    2-Base: СФ/124-3611 от 10 января 2019 до 15 января 2021
    3-Base: СФ/124-3612 от 10 января 2019 до 10 января 2022
    1-Lic: СФ/114-3613 от 10 января 2019 до 15 января 2021
    2-Lic: СФ/124-3614 от 10 января 2019 до 15 января 2021


    Вам просто пока везло и не сталкивались наверно с ПО которые начинает глючить в Вин-10 с ней.
  8. 25 Июня 2019 Втр 21:58:48
    Win7x32

    Имеем некие контейнеры один был запрошен c
    CSP ViPNet 4.2.11.58000
    другой с
    CSP ViPNet 4.2.2.36190 ! На 4.2.8 всё так же прсото под рукой этот для статистики...!
    ОНИ 100% экспортированые.

    190624-Медведь-Vip-4-2-11-58000 и Медведь-Vip-4-2-2-36190-ЭКС

    Каждый работает на своём месте, обменивается и получаем:

    В === CSP ViPNet 4.2.11.58000

    1) Проверка 2019-06-25_135316.jpg
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    2) Просмотр сертификата 2019-06-25_135615.jpg
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    3) Экспорт в pfx 2019-06-25_141435.jpg
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    4) Импорт из pfx (на том же месте)
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    4.1) Сверка КС Первичных и вторичных контейнеров
    2019-06-25_164405.jpg ; 2019-06-25_164527.jpg
    190624-Медведь-Vip-4-2-11-58000 - не совпадают
    Медведь-Vip-4-2-2-36190-ЭКС - не совпадают
    (Допускаю как норма т.к. могли доб. сертификаты корневые и т.п.)

    5) Проверка (1,2) Вторичных контейнеров после pfx
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    6) pfx С места 422
    Медведь-Vip-4-2-2-36190-ЭКС +
    6.1) Проверка (1,2) Вторичных контейнеров после pfx
    Медведь-Vip-4-2-2-36190-ЭКС +

    В === CSP ViPNet 4.2.2.36190

    1) Проверка 2019-06-25_165553.jpg
    190624-Медведь-Vip-4-2-11-58000 -
    Медведь-Vip-4-2-2-36190-ЭКС +

    2) Просмотр сертификата 2019-06-25_165813.jpg
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    3) Экспорт в pfx
    190624-Медведь-Vip-4-2-11-58000 - (нет т.к. не принимает пароль)
    Медведь-Vip-4-2-2-36190-ЭКС +

    4) Импорт из pfx (на том же месте)
    Медведь-Vip-4-2-2-36190-ЭКС +

    4.1) Сверка КС Первичных и вторичных контейнеров
    2019-06-25_170715.jpg
    Медведь-Vip-4-2-2-36190-ЭКС - разные
    (Допускаю как норма т.к. могли доб. сертификаты корневые и т.п.)

    5) Проверка (1,2) Вторичных контейнеров после pfx
    Медведь-Vip-4-2-2-36190-ЭКС +

    6) pfx С места 4211 2019-06-25_182600.jpg
    190624-Медведь-Vip-4-2-11-58000 - не признал криптопровайдер
    Медведь-Vip-4-2-2-36190-ЭКС - не признал криптопровайдер

    7) Проверка (1,2) Вторичного контейнера от pfx 422 разв. на месте 4211
    Медведь-Vip-4-2-2-36190-ЭКС
    2019-06-25_181049.jpg
    (1) - пароль не принимается ?!
    (2) + сертификат показывает

    В === ViPNet CSP 4.2.8.51670 cert (на дату 06.2019)

    1) Проверка 2019-06-25_185045.jpg
    190624-Медведь-Vip-4-2-11-58000 -
    Медведь-Vip-4-2-2-36190-ЭКС +

    2) Просмотр сертификата
    190624-Медведь-Vip-4-2-11-58000 +
    Медведь-Vip-4-2-2-36190-ЭКС +

    3) Проверка (1,2) Вторичного контейнера от pfx 422 разв. на месте 422
    Медведь-Vip-4-2-2-36190-ЭКС
    (1) + пароль принимается
    (2) + сертификат показывает

    4) Проверка (1,2) Вторичного контейнера от pfx 4211 разв. на месте 4211
    190624-Медведь-Vip-4-2-11-58000
    Медведь-Vip-4-2-2-36190-ЭКС
    (1) - пароль не принимается
    (2) - сертификат показывает

    3) Проверка (1,2) Вторичного контейнера от pfx 422 разв. на месте 4211
    Медведь-Vip-4-2-2-36190-ЭКС
    (1) пароль принимается
    (2) + сертификат показывает

    ========================
    ИТОГ проверки дефекта "не принимается контейнер от 4.2.11" - делает контейнеры только для "себя"

    Из последних попыток развернуть pfx есть предположение, что не верно распознаётся СКЗИ
    и решается или легко пофиксив реестр или какую то библиотеку, или второе.
  9. 12 Июля 2019 Птн 22:06:48
    Ещё один косяк 4.2.11 с налоговой, для ЮЛ так.
    Потом конечно поправят, но это не хорошо когда надо сейчас.





    Тех.п. приняла и думаю известна им причина давно, про исправление пока нет упоминания, только пока так:

    " ...на данный момент необходимо использовать ту версию, с которой был создан контейнер, иначе пароль от него не будет принят."

    Так что будем ждать, но 4.2.11 лучше не принимать.
    Как вариант можно 4.2.10 на Вин-10 пробовать, с ней таких проблем не наблюдалось.
  10. 12 Июля 2019 Птн 22:11:55


    Некоторое ПО при формировании закрытого ключа, делают его не экспортируемым,
    которые на другой версии делали нормально его. (Это сбой и вина 4.2.11)
  11. 12 Июля 2019 Птн 22:17:08
    Забей уже. Это российское ПО. Этим все сказано. Тут уже больше 100 лет все через опу. А то и того больше. Ниче, скоро придется трудиться(всем). Иначе никак.
  12. 12 Июля 2019 Птн 22:36:07
    kinslayer писал : Забей уже. Это российское ПО. Этим все сказано. Тут уже больше 100 лет все через опу. А то и того больше. Ниче, скоро придется трудиться(всем). Иначе никак.


    Забью когда в гроб слягу или вернее в мой забьют, а пока буду "бороться" Ну и вот, стало быть Мы краснеем!